文件 參考

圖層、向量和像素選單

圖層、向量和像素這三個選單裡的每一項:它新增什麼或做什麼,有快速鍵時是哪個鍵,以及什麼時候會變灰。

這三個選單依作用對象分工。圖層負責新增圖層、整理既有的圖層:群組、變形、排列順序、對齊和綁定。向量處理路徑的幾何。像素產生點陣圖,並處理像素選取範圍。只要沒有東西可作用,選單項目就會變灰,所以一個可用的項目,按下去總會做點什麼。

新圖層落在哪裡,只要在圖層面板裡設定一次:選取項目的上方、下方或群組內。圖層選單裡每一個新增項目都遵守它,複製和貼上也一樣。請看「圖層面板」。

圖層

新增圖層

選單頂端和圖層面板的新增那一排一一對應,順序也相同。每一個新增項目都始終可用,而且都是單獨一步復原。影像、影片和音訊圖層則從 檔案 ▸ 匯入 進來。

項目作用
骨骼新增一個骨骼圖層
網格新增一個空的網格圖層
像素新增一個像素圖層:單獨一張連續的點陣圖,沒有格
點陣格新增一個點陣格圖層。偏好設定裡的「新增點陣圖層時詢問尺寸」開著時,會先打開尺寸對話框,和從圖層面板新增時完全一樣
元件新增一個元件圖層
向量格新增一個向量格圖層:一個逐影格的向量容器,裝著它自己的繪畫格。它和形狀圖層不是同一回事
沒有新增空群組的項目。群組總是從一個選取開始,群組指令就在正下方。

群組和解散群組

項目快速鍵作用變灰的情況
群組Ctrl+G把選取的東西收進一個新的群組圖層選取的圖層少於兩個
解散群組Ctrl+Shift+G拆開被選取的群組,把它的子項提升一層,每一個都準確地留在畫面上原本的位置。有動畫的群組會先詢問,請看「整理圖層」裡的「組成群組」什麼都沒選取

轉換為元件和分離

項目快速鍵作用變灰的情況
轉換為元件F8把選取的圖層就地包成一個新元件,並在資源庫裡加上對應的項目什麼都沒選取,或開著一個動作
分離Ctrl+B把選取的元件實例變回它的圖層,放進一個保留它位置和關鍵影格的群組裡,所以什麼都不會移動選取的不是剛好一個元件實例,或開著一個動作

這兩個快速鍵都可以在偏好設定裡更改。畫布的右鍵選單裡也有同樣這兩項。請看「元件」。

變形

  • 水平翻轉 / 垂直翻轉:沿那條軸把圖層鏡射過去
  • 順時針旋轉 90° / 逆時針旋轉 90°:把圖層轉四分之一圈
這四項會在一個復原步驟裡作用在每一個選取的圖層上;自動關鍵影格開著時,翻轉或旋轉會被設成關鍵影格。鎖定的圖層不會被動到,而和它的群組一起被選取的圖層,只會跟著群組轉一次。

排列順序

項目作用變灰的情況
移至最前把圖層移到它那一疊的最上面它已經在最上面
往前移一層把圖層往上移一層它已經在最上面
往後移一層把圖層往下移一層它已經是最下面的圖層,就在內建攝影機上方
移至最後把圖層移到它那一疊的最下面,就在攝影機上方和往後移一層相同
排列順序子選單在這幾項旁邊顯示四個快速鍵(Ctrl+]、Ctrl+[、Ctrl+Shift+] 和 Ctrl+Shift+[),讀的是你目前的指定,每個鍵執行的都和它的項目完全一樣。

對齊

靠左對齊、水平置中對齊、靠右對齊、靠上對齊、垂直置中對齊和靠下對齊,會沿那條邊或那條軸把被選取的圖層排齊。對齊只要有一個頂點或一個圖層就能用,攝影機從不算在內。選取頂點時,它作用於頂點而不是它們所在的圖層:只選取一個頂點,會把它對齊到畫布,而不是移動它底下的整個圖層。

均分

依左邊緣均分、依水平中心均分、依右邊緣均分、依上邊緣均分、依垂直中心均分、依下邊緣均分、水平均分間距和垂直均分間距,會把被選圖層之間的間距調勻。

均分需要三個作用對象:只要選取了任何頂點,就是三個頂點,否則是三個圖層。水平均分間距和垂直均分間距只針對圖層,需要三個圖層且沒有選取任何頂點。每一項都遵循和工具列上對應按鈕相同的規則,小到無法再分的範圍會保持原樣,而不是把所有東西都堆到第一個上。

綁定和解除綁定

綁定 (Enter) 和解除綁定 (U) 執行的是骨骼綁定工具選項列上那兩顆按鈕的同樣兩個指令。只有在編輯模式下拿著這個工具時它們才可用,因為只有這種狀態下才能綁定。

選取兩個圖層時打開的圖層選單,排列順序子選單展開著。
選取兩個圖層時打開的圖層選單,排列順序子選單展開著。

向量

向量裝著一切改變路徑幾何的東西:整個圖層的轉換、合併形狀的兩種方法、節點和鋼筆工具選項列上的路徑操作,以及頂點熔接。

轉換

項目作用變灰的情況
轉為曲線把一個活的形狀(矩形、星形等形狀工具畫的形狀,或任何帶圓角的路徑)變成一般的可編輯點。作用於每一個適用的被選形狀圖層被選取的形狀圖層裡沒有活的形狀,也沒有帶圓角半徑的
擴展筆畫把筆畫變成一個獨立、填色的輪廓。同時帶填色的形狀會保留填色,輪廓以新圖層加在上面被選取的形狀圖層都沒有看得見的筆畫
轉換為網格把被選取的形狀圖層包進一個網格圖層,讓它可以變形主要選取的不是形狀圖層
建立路徑線在被選圖層的正上方,建立一個沿著它的運動路徑描出來的形狀圖層。請看「運動路徑」這個圖層的位置關鍵影格少於兩個,或它是攝影機

布林運算和幾何

這兩個子選單用兩種不同的方式合併形狀,也遵循兩種不同的規則。

  • 布林運算裡有聯集(液態形狀)、減去、交集和互斥。它是活的、非破壞性的:被選取的圖層會裝進一個新的布林群組,最底下那個之上的每一個圖層都接受你選的運算,原本的圖層在裡面依然可以編輯。它需要選取兩個圖層,攝影機和父層也被選取的圖層不算,所以合併兩個群組和合併兩個形狀一樣容易。
  • 幾何裡有相加(聯集)、減去、交集、互斥和分割。它們就是工具列上的路徑管理員按鈕,是破壞性的,每一項在它的工具列按鈕可用時才可用。

每種運算產生什麼,請看「布林與液態形狀」。

路徑操作

連接曲線、封閉路徑、中斷曲線、分割曲線、反轉方向、簡化和起始頂點,是節點和鋼筆工具選項列上的曲線按鈕。每一項在它的按鈕可用時才可用,作用於你用這兩個工具選取的點。其他工具留下的點選取不會被作用到。

  • 連接曲線(Ctrl+J)會透過兩個被選取的端點封閉一條路徑,或把兩條開放路徑頭尾相接。
  • 封閉路徑會封閉一條有三個以上點的開放路徑。中斷曲線會在被選取的點把一條封閉路徑斷開。
  • 分割曲線會在被選點之後那一段的中點加一個點。
  • 反轉方向會把路徑的方向倒過來。簡化會用更少的點重新擬合整條路徑。
  • 起始頂點會把唯一被選取的那個點設為它所在封閉輪廓的第一個點。它需要節點工具。

線段轉直線和線段轉曲線,會把兩個以上相鄰被選點之間的線段拉直或彎曲。兩者都需要節點工具。

熔接

項目作用變灰的情況
熔接頂點把每一個被選取的頂點熔接到你選的第一個頂點上節點工具沒有作用中,或被選取的頂點少於兩個
取消熔接頂點拿掉碰到每一個被選頂點的所有熔接節點工具沒有作用中,或被選取的頂點都沒有熔接

像素

像素會從其他圖層產生點陣圖,並裝著所有作用於像素選取範圍的指令。

項目作用變灰的情況
點陣化打開和圖層右鍵選單裡的點陣化相同的確認,然後把圖層變成像素圖層,效果可以烘進去也可以不烘。向量格或點陣格圖層,或是包含其中之一的群組,會變成每個格都畫好的點陣格圖層主要選取的是攝影機、骨骼圖層,或已經是像素圖層
轉換為點陣把一個影像或像素圖層變成點陣格圖層,原本的畫面成為第一格主要選取的不是影像或像素圖層
轉換為像素圖層把只有一張畫的點陣格圖層變成像素圖層主要選取的不是點陣格圖層,或它裝著不只一張畫
選取範圍下面的子選單從不
調整被選點陣圖層的顏色調整,見下文除非剛好選取一個可編輯的點陣格或像素圖層,否則裡面的項目都是灰的
濾鏡被選點陣圖層的模糊、銳利化、雜訊等濾鏡,見下文除非剛好選取一個可編輯的點陣格或像素圖層,否則裡面的項目都是灰的
變形像素把整個圖層的像素水平或垂直翻轉,或往任一方向轉 90°,或轉 180°。點陣格圖層的每一格會一起轉,圖層在畫布上的位置不變沒有剛好選取一個可編輯的點陣圖層
修剪圖層把像素圖層的點陣圖縮到有畫東西的範圍,畫布上的東西一個也不會移動主要選取的不是可編輯的像素圖層
向下合併把被選圖層連同它的不透明度、混合模式和效果畫進它下面的圖層,然後移除它。下面那個圖層不是點陣圖時,會先變成像素圖層;下面是點陣格圖層時,會落在畫面上的那一張畫裡。把形狀圖層合併到向量格圖層上時,它會以向量形狀的身分,在同樣的位置、帶著它的關鍵影格,進到這一影格正在顯示的那個格裡。隱藏的圖層不能向下合併。畫布和圖層面板的右鍵選單裡也有沒有剛好選取一個圖層、同一個群組裡它下面沒有圖層、其中一個無法合併,或是合併會把動畫丟掉:被選圖層有移動、有變化或顯示好幾個格,或是下面不是點陣圖的圖層內部有運動
合併可見圖層至新圖層在最上面新增一個像素圖層,裝著畫布在這個影格上顯示的樣子。原本的那些圖層保持原樣沒有打開的文件
清除擦掉被選圖層上選取範圍裡的像素,羽化的邊緣處則柔和地淡出沒有像素選取範圍、圖層不是點陣圖,或它鎖定了透明像素
將選取範圍儲存為筆尖把選取範圍框住的東西存成一個可重複使用的筆刷筆尖沒有像素選取範圍
鎖定透明像素依主要圖層的狀態,一次替所有被選取的點陣圖層打開或關閉鎖定透明像素沒有選取點陣圖層
像素模式在向量繪畫和像素畫之間切換專案,和工具列上的向量/像素切換是同一個開關沒有打開的文件

選取範圍

項目作用變灰的情況
全選選取整張畫布沒有打開的文件
取消全選先確定任何浮動的像素,再清掉像素選取範圍沒有像素選取範圍
反轉選取選取原本沒被選取的一切沒有像素選取範圍
從圖層建立選取範圍選取被選圖層畫出來的東西,柔邊也包含在內沒有選取圖層,或選的是攝影機、骨骼圖層或音訊圖層
擴張把選取範圍往外擴大沒有像素選取範圍
縮減把選取範圍往內縮小沒有像素選取範圍
羽化把選取範圍的邊緣柔化沒有像素選取範圍
邊界先詢問寬度(1 到 200 px,一開始是 8 px),再把選取範圍變成沿著邊緣、那個寬度的一條帶子沒有像素選取範圍
平滑先詢問半徑(1 到 100 px,一開始是 4 px),再把選取範圍的角和細小的鋸齒磨圓沒有像素選取範圍
填滿選取範圍在被選圖層上用目前的顏色把選取範圍塗滿沒有像素選取範圍,或被選圖層不是可編輯的點陣圖
描邊選取範圍先詢問寬度(0.5 到 250 px,一開始是 4 px)和位置(內部、中心或外部),再用目前的顏色畫出選取範圍的外框沒有像素選取範圍,或沒有剛好選取一個可編輯的點陣圖層
選取範圍轉為形狀新增一個形狀圖層,它的外框沿著選取範圍走沒有像素選取範圍
將畫布裁切為選取範圍把畫布變成選取範圍的大小,作品在裡面的位置保持不動沒有像素選取範圍

擴張、縮減和羽化用的是選取框工具選項列上設好的數值,選單會在每一項旁邊以像素顯示這些數值,所以按之前你就知道會發生什麼。

和 編輯 ▸ 取消全選 不同,像素選單裡的取消全選從不碰圖層選取。沒有像素選取範圍時它只會變灰。

調整和濾鏡

調整裡有亮度/對比、色相/飽和度、色階、曲線、負片效果、去除飽和度、色調分離和臨界值。濾鏡裡有高斯模糊、動態模糊、遮色片銳利化調整、增加雜訊、中間值、馬賽克和位移。它們會永久改變被選點陣格或像素圖層的像素,每一項都是一個步驟記錄。

負片效果和去除飽和度會立刻套用。其他的則會打開一個小視窗讓你設定,預覽開著時(預設就是開的),畫布會即時顯示結果。按「確定」或 Enter 會套用,按「取消」或 Esc 則把像素還原;在你結束應用程式之前,視窗會記住每一項你上次用的數值。每一項設定請看「調整與濾鏡」。在點陣格圖層上,勾選「此圖層的所有格」會把它套用到這個圖層的每一張畫上,而不只是畫面上的那一張。

有像素選取範圍時,只有被選取的像素會改變,羽化的邊緣處則柔和地過渡。鎖定透明像素會讓每個像素的覆蓋率保持原樣,所以模糊不會擴散到空白的地方。

將選取範圍儲存為筆尖會照你看到的樣子算繪場景,並裁切到選取範圍,所以它不取決於選取的是哪個圖層。這個筆尖之後會出現在筆刷工作室的筆尖選擇器裡。請看「筆刷筆尖與紙紋」。

在 macOS 上,這三個選單在系統選單列裡,遵循同樣的可用規則,只是在那裡變形和排列順序子選單從不變灰。